re = /(?i)^(TECHNICAL|SUPPORT|ADMINISTRATIVE|BILLING|OTHER)$/m
str = 'TECHNICAL
SUPPORT
ADMINISTRATIVE
BILLING
OTHER
technical
tecHNICAL
AdMiNiStRaTiVe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end