import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^(TECHNICAL|SUPPORT|ADMINISTRATIVE|BILLING|OTHER)$";
final String string = "TECHNICAL\n"
+ "SUPPORT\n"
+ "ADMINISTRATIVE\n"
+ "BILLING\n"
+ "OTHER\n"
+ "technical\n"
+ "tecHNICAL\n"
+ "AdMiNiStRaTiVe";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}