package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:-?(?:[1-9]\d*)?)|0)$`)
var str = `OK:
-
-10
-54
66
0
1
NOK:
+
+1
-010
010`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}