$re = '/^(?:(?:-?(?:[1-9]\d*)?)|0)$/m';
$str = 'OK:
-
-10
-54
66
0
1
NOK:
+
+1
-010
010';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);