using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{4})\s+([^\d]+),\s+([^\d]+)\s+(\d+(?:\/[^\d\s]*)?)\.?(?:\s+(\d+\.[^\d\s]*))?";
string input = @"5630 Békés, Ady Endre u. 5/A. 3.em. 9.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}