$re = '/(\d{4})\s+([^\d]+),\s+([^\d]+)\s+(\d+(?:\/[^\d\s]*)?)\.?(?:\s+(\d+\.[^\d\s]*))?/mux';
$str = '5630 Békés, Ady Endre u. 5/A. 3.em. 9.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);