package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{4})\s+([^\d]+),\s+([^\d]+)\s+(\d+(?:\/[^\d\s]*)?)\.?(?:\s+(\d+\.[^\d\s]*))?`)
var str = `5630 Békés, Ady Endre u. 5/A. 3.em. 9.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}