re = /(\d{4})\s+([^\d]+),\s+([^\d]+)\s+(\d+(?:\/[^\d\s]*)?)\.?(?:\s+(\d+\.[^\d\s]*))?/mx
str = '5630 Békés, Ady Endre u. 5/A. 3.em. 9.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end