#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<([^>\s]+)[^>]*>(?:\s*(?:<br \/>|<br>| | | | | | | )\s*|\s*)*<\/\1>"
Local $sString = "<div class="redactor-styles redactor-in redactor-in-0" dir="ltr" aria-labelledby="redactor-voice-0" role="presentation" style="min-height: 150px;" contenteditable="true"><p><br></p><p></p>" & @CRLF & _
"<p><strong>Ячейка1</strong></p><p></p>" & @CRLF & _
"<p></p>" & @CRLF & _
"<p><strong>Ячейка2</strong></p><p></p>" & @CRLF & _
"<p></p>" & @CRLF & _
"<p><strong>Ячейка3</strong></p><p></p>" & @CRLF & _
"<p></p>" & @CRLF & _
"<p><strong>Ячейка4</strong></p><p></p>" & @CRLF & _
"<p></p>" & @CRLF & _
"<p><strong>Ячейка5</strong></p><p></p>" & @CRLF & _
"<p></p>" & @CRLF & _
"<p><strong>Ячейка 6</strong></p><p></p>" & @CRLF & _
"<p></p>" & @CRLF & _
"<p><strong>Ячейка7</strong></p><p></p>" & @CRLF & _
"<p></p>" & @CRLF & _
"<p><strong>Ячейка8</strong></p><p></p>" & @CRLF & _
"<p></p>" & @CRLF & _
"<p><strong>Ячейка8</strong></p><p></p>" & @CRLF & _
"<p></p>" & @CRLF & _
"<p><strong>Ячейка10</strong></p><p></p></div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")