const regex = /<([^>\s]+)[^>]*>(?:\s*(?:<br \/>|<br>| | | | | | | )\s*|\s*)*<\/\1>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<([^>\\s]+)[^>]*>(?:\\s*(?:<br \\\/>|<br>| | | | | | | )\\s*|\\s*)*<\\\/\\1>', 'gi')
const str = `<div class="redactor-styles redactor-in redactor-in-0" dir="ltr" aria-labelledby="redactor-voice-0" role="presentation" style="min-height: 150px;" contenteditable="true"><p><br></p><p></p>
<p><strong>Ячейка1</strong></p><p></p>
<p></p>
<p><strong>Ячейка2</strong></p><p></p>
<p></p>
<p><strong>Ячейка3</strong></p><p></p>
<p></p>
<p><strong>Ячейка4</strong></p><p></p>
<p></p>
<p><strong>Ячейка5</strong></p><p></p>
<p></p>
<p><strong>Ячейка 6</strong></p><p></p>
<p></p>
<p><strong>Ячейка7</strong></p><p></p>
<p></p>
<p><strong>Ячейка8</strong></p><p></p>
<p></p>
<p><strong>Ячейка8</strong></p><p></p>
<p></p>
<p><strong>Ячейка10</strong></p><p></p></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}