use strict;
my $str = '<div class="redactor-styles redactor-in redactor-in-0" dir="ltr" aria-labelledby="redactor-voice-0" role="presentation" style="min-height: 150px;" contenteditable="true"><p><br></p><p></p>
<p><strong>Ячейка1</strong></p><p></p>
<p></p>
<p><strong>Ячейка2</strong></p><p></p>
<p></p>
<p><strong>Ячейка3</strong></p><p></p>
<p></p>
<p><strong>Ячейка4</strong></p><p></p>
<p></p>
<p><strong>Ячейка5</strong></p><p></p>
<p></p>
<p><strong>Ячейка 6</strong></p><p></p>
<p></p>
<p><strong>Ячейка7</strong></p><p></p>
<p></p>
<p><strong>Ячейка8</strong></p><p></p>
<p></p>
<p><strong>Ячейка8</strong></p><p></p>
<p></p>
<p><strong>Ячейка10</strong></p><p></p></div>';
my $regex = qr/<([^>\s]+)[^>]*>(?:\s*(?:<br \/>|<br>| | | | | | | )\s*|\s*)*<\/\1>/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}