re = /<([^>\s]+)[^>]*>(?:\s*(?:<br \/>|<br>| | | | | | | )\s*|\s*)*<\/\1>/i
str = '<div class="redactor-styles redactor-in redactor-in-0" dir="ltr" aria-labelledby="redactor-voice-0" role="presentation" style="min-height: 150px;" contenteditable="true"><p><br></p><p></p>
<p><strong>Ячейка1</strong></p><p></p>
<p></p>
<p><strong>Ячейка2</strong></p><p></p>
<p></p>
<p><strong>Ячейка3</strong></p><p></p>
<p></p>
<p><strong>Ячейка4</strong></p><p></p>
<p></p>
<p><strong>Ячейка5</strong></p><p></p>
<p></p>
<p><strong>Ячейка 6</strong></p><p></p>
<p></p>
<p><strong>Ячейка7</strong></p><p></p>
<p></p>
<p><strong>Ячейка8</strong></p><p></p>
<p></p>
<p><strong>Ячейка8</strong></p><p></p>
<p></p>
<p><strong>Ячейка10</strong></p><p></p></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end