use strict;
my $str = '000000, Регион, Населенный пункт, Название улицы, 25';
my $regex = qr/(.*?,.*?,.*?),.*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";