using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"charset=""UTF-8""\s*(.+?)\s+-";
string input = @"--0000000000008222fd058bf67e3a Content-Type: text/plain; charset=""UTF-8"" Thi is test message --0000000000008222fd058bf67e3a Content-Type: text/html; charset=""UTF-8""
Thi is test message";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}