package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)charset="UTF-8"\s*(.+?)\s+-`)
var str = `--0000000000008222fd058bf67e3a Content-Type: text/plain; charset="UTF-8" Thi is test message --0000000000008222fd058bf67e3a Content-Type: text/html; charset="UTF-8"
Thi is test message`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}