// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)charset="UTF-8"\s*(.+?)\s+-"#).unwrap();
let string = "--0000000000008222fd058bf67e3a Content-Type: text/plain; charset=\"UTF-8\" Thi is test message --0000000000008222fd058bf67e3a Content-Type: text/html; charset=\"UTF-8\"
Thi is test message";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}