const regex = /charset="UTF-8"\s*(.+?)\s+-/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('charset="UTF-8"\\s*(.+?)\\s+-', 'gs')
const str = `--0000000000008222fd058bf67e3a Content-Type: text/plain; charset="UTF-8" Thi is test message --0000000000008222fd058bf67e3a Content-Type: text/html; charset="UTF-8"
Thi is test message`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}