using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=>)([[:upper:]]+)(?=<)";
string input = @"<p><span class=""w"">RED</span><br><span class=""a"">DOG</span>USA</p>
<p><span class=""w"">GREEN</span><br><span class=""a"">CAT</span><br>SPAIN</p>
<p><span class=""w"">BLUE</span><br><span class=""a"">MOUSE</span>FRANCE</p>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}