$re = '/(?<=>)([[:upper:]]+)(?=<)/m';
$str = '<p><span class="w">RED</span><br><span class="a">DOG</span>USA</p>
<p><span class="w">GREEN</span><br><span class="a">CAT</span><br>SPAIN</p>
<p><span class="w">BLUE</span><br><span class="a">MOUSE</span>FRANCE</p>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);