import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=>)([[:upper:]]+)(?=<)";
final String string = "<p><span class=\"w\">RED</span><br><span class=\"a\">DOG</span>USA</p>\n"
+ "<p><span class=\"w\">GREEN</span><br><span class=\"a\">CAT</span><br>SPAIN</p>\n"
+ "<p><span class=\"w\">BLUE</span><br><span class=\"a\">MOUSE</span>FRANCE</p>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}