const regex = /(?<=>)([[:upper:]]+)(?=<)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=>)([[:upper:]]+)(?=<)', 'gm')
const str = `<p><span class="w">RED</span><br><span class="a">DOG</span>USA</p>
<p><span class="w">GREEN</span><br><span class="a">CAT</span><br>SPAIN</p>
<p><span class="w">BLUE</span><br><span class="a">MOUSE</span>FRANCE</p>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}