#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=appName-).*?(?=\.jar$)"
Local $sString = "/opt/appName/someappName-2.0.0-000.jar" & @CRLF & _
"/opt/appName/appName-1.0.0-TTT-aa444.jar" & @CRLF & _
"/opt/appName/appName-1.0.0-rrr1115.jar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")