$re = '/(?<=appName-).*?(?=\.jar$)/m';
$str = '/opt/appName/someappName-2.0.0-000.jar
/opt/appName/appName-1.0.0-TTT-aa444.jar
/opt/appName/appName-1.0.0-rrr1115.jar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);