import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=appName-).*?(?=\\.jar$)";
final String string = "/opt/appName/someappName-2.0.0-000.jar\n"
+ "/opt/appName/appName-1.0.0-TTT-aa444.jar\n"
+ "/opt/appName/appName-1.0.0-rrr1115.jar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}