re = /(?<=appName-).*?(?=\.jar$)/m
str = '/opt/appName/someappName-2.0.0-000.jar
/opt/appName/appName-1.0.0-TTT-aa444.jar
/opt/appName/appName-1.0.0-rrr1115.jar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end