using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<="")[\w\s]+(?="")\b|\w+";
string input = @"""texto0 texto1 texto2"" texto3 ""texto4""
texto1 texto2 ""texto3 texto4"" texto5
""texto0 texto1 texto2"" texto3 ""texto4""
""texto0 texto1"" texto2
texto0 texto1 ""texto2 texto3""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}