re = /(?<=")[\w\s]+(?=")\b|\w+/
str = '"texto0 texto1 texto2" texto3 "texto4"
texto1 texto2 "texto3 texto4" texto5
"texto0 texto1 texto2" texto3 "texto4"
"texto0 texto1" texto2
texto0 texto1 "texto2 texto3"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end