import Foundation
let pattern = #"(?<=")[\w\s]+(?=")\b|\w+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"texto0 texto1 texto2" texto3 "texto4"
texto1 texto2 "texto3 texto4" texto5
"texto0 texto1 texto2" texto3 "texto4"
"texto0 texto1" texto2
texto0 texto1 "texto2 texto3"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)