#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^D7[5]{1}............"
Local $sString = "D74000000016CCC " & @CRLF & _
"D7400000001813B " & @CRLF & _
"D7400000001991B " & @CRLF & _
"D74000000019E07 " & @CRLF & _
"D74000000019F99 " & @CRLF & _
"D7400000001A4A4 " & @CRLF & _
"D7400000001A53E" & @CRLF & _
"D7400000001A5C2" & @CRLF & _
"D7500000008E44C " & @CRLF & _
"D7500000008F94E " & @CRLF & _
"D750000000901B2 " & @CRLF & _
"D75000000095FB1" & @CRLF & _
"D7500000009B218" & @CRLF & _
"D750000000A36E1" & @CRLF & _
"D750000000AD9AA" & @CRLF & _
"D750000001135DB" & @CRLF & _
"D75000000118DC1" & @CRLF & _
"D75000000119E91" & @CRLF & _
"D75............" & @CRLF & _
"D74............" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")