use strict;
my $str = 'D74000000016CCC
D7400000001813B
D7400000001991B
D74000000019E07
D74000000019F99
D7400000001A4A4
D7400000001A53E
D7400000001A5C2
D7500000008E44C
D7500000008F94E
D750000000901B2
D75000000095FB1
D7500000009B218
D750000000A36E1
D750000000AD9AA
D750000001135DB
D75000000118DC1
D75000000119E91
D75............
D74............
';
my $regex = qr/^D7[5]{1}............/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}