import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^D7[5]{1}............";
final String string = "D74000000016CCC \n"
+ "D7400000001813B \n"
+ "D7400000001991B \n"
+ "D74000000019E07 \n"
+ "D74000000019F99 \n"
+ "D7400000001A4A4 \n"
+ "D7400000001A53E\n"
+ "D7400000001A5C2\n"
+ "D7500000008E44C \n"
+ "D7500000008F94E \n"
+ "D750000000901B2 \n"
+ "D75000000095FB1\n"
+ "D7500000009B218\n"
+ "D750000000A36E1\n"
+ "D750000000AD9AA\n"
+ "D750000001135DB\n"
+ "D75000000118DC1\n"
+ "D75000000119E91\n"
+ "D75............\n"
+ "D74............\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}