# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^D7[5]{1}............"
test_str = ("D74000000016CCC \n"
"D7400000001813B \n"
"D7400000001991B \n"
"D74000000019E07 \n"
"D74000000019F99 \n"
"D7400000001A4A4 \n"
"D7400000001A53E\n"
"D7400000001A5C2\n"
"D7500000008E44C \n"
"D7500000008F94E \n"
"D750000000901B2 \n"
"D75000000095FB1\n"
"D7500000009B218\n"
"D750000000A36E1\n"
"D750000000AD9AA\n"
"D750000001135DB\n"
"D75000000118DC1\n"
"D75000000119E91\n"
"D75............\n"
"D74............\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.