using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w+:([Tt][0-9]|[Cc])$";
string input = @"test:T1
test:C
test:T0
test:T1
test_TTES_SJ:T1
:T1
:T1
test:C1
!#$%^&*:T0
a a:T1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}