$re = '/^\w+:([Tt][0-9]|[Cc])$/m';
$str = 'test:T1
test:C
test:T0
test:T1
test_TTES_SJ:T1
:T1
:T1
test:C1
!#$%^&*:T0
a a:T1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);