import re
regex = re.compile(r"^\w+:([Tt][0-9]|[Cc])$", flags=re.MULTILINE)
test_str = ("test:T1\n"
"test:C\n"
"test:T0\n"
"test:T1\n"
"test_TTES_SJ:T1\n\n"
":T1\n"
" :T1\n"
"test:C1\n"
"!#$%^&*:T0\n"
"a a:T1\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")