package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+:([Tt][0-9]|[Cc])$`)
var str = `test:T1
test:C
test:T0
test:T1
test_TTES_SJ:T1
:T1
:T1
test:C1
!#$%^&*:T0
a a:T1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}