using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({[^}]*?variants[^{]*?})";
string input = @"cart = {""note\"":null,\""cart_level_discount_applications\"":[]};\n MAKEBECOOL_BUNDLES.product = {""id\"":7148755124373,\""title\"":\""Couch Jumper White 6 Pack\"",\""handle\"":\""couch-jumper-white-6-pack\"",\""description\"":\""\\u0026lt;p\\u0026gt;Ultra-comfortable, ""variants"": anti-bacterial socks You’re gonna love them as much as we do! Guaranteed!\\u0026lt;\\\/p\\u0026gt;\""};\n MAKEBECOOL_BUNDLES.isPhysicalBundle = true;\n";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}