import Foundation
let pattern = #"({[^}]*?variants[^{]*?})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"cart = {"note\":null,\"cart_level_discount_applications\":[]};\n MAKEBECOOL_BUNDLES.product = {"id\":7148755124373,\"title\":\"Couch Jumper White 6 Pack\",\"handle\":\"couch-jumper-white-6-pack\",\"description\":\"\\u0026lt;p\\u0026gt;Ultra-comfortable, "variants": anti-bacterial socks You’re gonna love them as much as we do! Guaranteed!\\u0026lt;\\\/p\\u0026gt;\"};\n MAKEBECOOL_BUNDLES.isPhysicalBundle = true;\n"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)