use strict;
my $str = 'cart = {"note\\":null,\\"cart_level_discount_applications\\":[]};\\n MAKEBECOOL_BUNDLES.product = {"id\\":7148755124373,\\"title\\":\\"Couch Jumper White 6 Pack\\",\\"handle\\":\\"couch-jumper-white-6-pack\\",\\"description\\":\\"\\\\u0026lt;p\\\\u0026gt;Ultra-comfortable, "variants": anti-bacterial socks You’re gonna love them as much as we do! Guaranteed!\\\\u0026lt;\\\\\\/p\\\\u0026gt;\\"};\\n MAKEBECOOL_BUNDLES.isPhysicalBundle = true;\\n';
my $regex = qr/({[^}]*?variants[^{]*?})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}