# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"({[^}]*?variants[^{]*?})"
test_str = "cart = {\"note\\\":null,\\\"cart_level_discount_applications\\\":[]};\\n MAKEBECOOL_BUNDLES.product = {\"id\\\":7148755124373,\\\"title\\\":\\\"Couch Jumper White 6 Pack\\\",\\\"handle\\\":\\\"couch-jumper-white-6-pack\\\",\\\"description\\\":\\\"\\\\u0026lt;p\\\\u0026gt;Ultra-comfortable, \"variants\": anti-bacterial socks You’re gonna love them as much as we do! Guaranteed!\\\\u0026lt;\\\\\\/p\\\\u0026gt;\\\"};\\n MAKEBECOOL_BUNDLES.isPhysicalBundle = true;\\n"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.