#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?<=\n)|^) +| +$| +"
Local $sString = " Asdf" & @CRLF & _
" asd asd asd" & @CRLF & _
" asd asd asd " & @CRLF & _
" " & @CRLF & _
" ssd "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)