re = /((?<=\n)|^) +| +$| +/m
str = ' Asdf
asd asd asd
asd asd asd
ssd '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result