const regex = new RegExp('((?<=\\n)|^) +| +$| +', 'gm')
const str = ` Asdf
asd asd asd
asd asd asd
ssd `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);