import re
regex = re.compile(r"((?<=\n)|^) +| +$| +", flags=re.MULTILINE)
test_str = (" Asdf\n"
" asd asd asd\n"
" asd asd asd \n"
" \n"
" ssd ")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)