package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[actgACTG]+$`)
var str = `ATGGCAAT
atg
AATG!4
this input contains all the char but is in the wrong format`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}