re = /^[actgACTG]+$/m
str = 'ATGGCAAT
atg
AATG!4
this input contains all the char but is in the wrong format'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end