const regex = /^[actgACTG]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[actgACTG]+$', 'gm')
const str = `ATGGCAAT
atg
AATG!4
this input contains all the char but is in the wrong format`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}