using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[a-záéíóúñ])(?=.*[A-ZÁÉÍÓÚÑ])(?=.*[0-9])\S{8,16}$";
string input = @"1234567890123456 # Para medir los passwords de abajo
MiPasswordBueno1
EstePasswordEsMuyLargo1234
Est4PasswordOK
C0n!Símb0loS
EsC0rt0
sinmayusculas1
SINMINUCULAS1
SiNnUmErOs
F0J1mDmm
·$""$·""Aa0
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}