$re = '/^(?=.*[a-záéíóúñ])(?=.*[A-ZÁÉÍÓÚÑ])(?=.*[0-9])\S{8,16}$/m';
$str = '1234567890123456 # Para medir los passwords de abajo
MiPasswordBueno1
EstePasswordEsMuyLargo1234
Est4PasswordOK
C0n!Símb0loS
EsC0rt0
sinmayusculas1
SINMINUCULAS1
SiNnUmErOs
F0J1mDmm
·$"$·"Aa0
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);