const regex = /^(?=.*[a-záéíóúñ])(?=.*[A-ZÁÉÍÓÚÑ])(?=.*[0-9])\S{8,16}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[a-záéíóúñ])(?=.*[A-ZÁÉÍÓÚÑ])(?=.*[0-9])\\S{8,16}$', 'gm')
const str = `1234567890123456 # Para medir los passwords de abajo
MiPasswordBueno1
EstePasswordEsMuyLargo1234
Est4PasswordOK
C0n!Símb0loS
EsC0rt0
sinmayusculas1
SINMINUCULAS1
SiNnUmErOs
F0J1mDmm
·\$"\$·"Aa0
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}